Editing /boot/

Jump to: navigation, search

Warning: You are not logged in. Your IP address will be publicly visible if you make any edits. If you log in or create an account, your edits will be attributed to your username, along with other benefits.

The edit can be undone. Please check the comparison below to verify that this is what you want to do, and then save the changes below to finish undoing the edit.
Latest revision Your text
Line 52: Line 52:
 
|-
 
|-
 
|/boot/boot
 
|/boot/boot
|[https://www.unix.com/man-page/freebsd/8/boot/ system bootstrapping procedures] A single, full-blown file, boot (/boot/boot), is what ultimately is written to disk.
+
|[https://www.unix.com/man-page/freebsd/8/boot/ system bootstrapping procedures]
 
|-
 
|-
 
|/boot/boot0
 
|/boot/boot0
|[https://www.freebsd.org/doc/en/books/arch-handbook/boot-boot0.html The Master Boot Record] It is a small 512-byte file.
+
|
 
|-
 
|-
 
|/boot/boot0sio
 
|/boot/boot0sio
|Image for serial consoles (COM1,9600,8,N,1,MODEM) [https://www.unix.com/man-page/FreeBSD/8/boot0cfg/ see: FILES]
+
|
 
|-
 
|-
 
|/boot/boot1
 
|/boot/boot1
|[https://www.freebsd.org/doc/en/books/arch-handbook/boot-boot1.html boot1 is the next step in the boot-loading sequence]
+
|
 
|-
 
|-
 
|/boot/boot1.efi
 
|/boot/boot1.efi
|[https://www.freebsd.org/cgi/man.cgi?query=uefi&sektion=8&manpath=freebsd-release-ports UEFI] The default UEFI boot configuration for FreeBSD installs boot1.efi in the default path.
+
|
 
|-
 
|-
 
|/boot/boot1.efifat
 
|/boot/boot1.efifat
|[https://www.freebsd.org/cgi/man.cgi?query=uefi&sektion=8&manpath=freebsd-release-ports UEFI]  [https://www.freebsd.org/cgi/man.cgi?query=msdosfs&sektion=5&apropos=0&manpath=FreeBSD+12.1-RELEASE+and+Ports msdosfs(5)] FAT file system image containing boot1.efi for use by [https://www.freebsd.org/cgi/man.cgi?query=bsdinstall&sektion=8&apropos=0&manpath=FreeBSD+12.1-RELEASE+and+Ports bsdinstall(8)] and the bootcode argument to [https://www.freebsd.org/cgi/man.cgi?query=gpart&sektion=8&apropos=0&manpath=FreeBSD+12.1-RELEASE+and+Ports gpart(8)].
+
|
 
|-
 
|-
 
|/boot/boot2
 
|/boot/boot2
|boot2 is much bigger than boot0 and boot1, holding both the BTX server and the boot2 client
+
|
 
|-
 
|-
 
|/boot/brand.4th
 
|/boot/brand.4th
|[https://www.unix.com/man-page/freebsd/8/brand.4th/ FreeBSD ASCII art boot module]
+
|
 
|-
 
|-
 
|/boot/brand-fbsd.4th
 
|/boot/brand-fbsd.4th
|[https://github.com/freebsd/freebsd/blob/master/stand/forth/brand.4th like brand.4th]
+
|
 
|-
 
|-
 
|/boot/cdboot
 
|/boot/cdboot
|Boot from CD
+
|
 
|-
 
|-
 
|/boot/check-password.4th
 
|/boot/check-password.4th
Line 112: Line 112:
 
|-
 
|-
 
|/boot/isoboot
 
|/boot/isoboot
|Boot from iso
+
|
 
|-
 
|-
 
|/boot/loader
 
|/boot/loader
Line 118: Line 118:
 
|-
 
|-
 
|/boot/loader.4th
 
|/boot/loader.4th
|[https://www.unix.com/man-page/freebsd/8/loader/ loader(8)] bootstrapping script. [https://www.unix.com/man-page/freebsd/8/loader.4th/ loader.conf processing tools]
+
|
 
|-
 
|-
 
|[[/boot/loader.conf]]
 
|[[/boot/loader.conf]]
Line 127: Line 127:
 
|-
 
|-
 
|/boot/loader.rc
 
|/boot/loader.rc
|loader bootstrapping script. Standard: /boot/loader.rc: include /boot/loader.4th
+
|loader bootstrapping script.
 
|-
 
|-
 
|/boot/loader.rc.local
 
|/boot/loader.rc.local
Line 133: Line 133:
 
|-
 
|-
 
|/boot/loader_4th
 
|/boot/loader_4th
|
+
|[https://www.unix.com/man-page/freebsd/8/loader.4th/ loader.conf processing tools]
  
 
|-
 
|-
Line 167: Line 167:
 
|-
 
|-
 
|/boot/mbr
 
|/boot/mbr
|Master Boot Record
+
|
 
|-
 
|-
 
|/boot/menu.4th
 
|/boot/menu.4th
Line 206: Line 206:
 
|-
 
|-
 
|/boot/version.4th
 
|/boot/version.4th
| The file that goes by the name of [https://www.unix.com/man-page/freebsd/8/version.4th/ version.4th] is a set of commands designed to draw the boot loader version at the bottom-right of the screen.  The commands of [https://www.unix.com/man-page/freebsd/8/version.4th version.4th] by themselves are not enough for most uses.  Please refer to the examples below for the most common situations, and to [https://www.unix.com/man-page/freebsd/8/loader/ loader(8)] for additional commands.
+
|[https://www.unix.com/man-page/freebsd/8/version.4th/] The file that goes by the name of version.4th is a set of commands designed to draw the boot loader version at the bottom-right of the screen.  The commands of version.4th by themselves are not enough for most uses.  Please refer to the examples below for the most common situations, and to loader(8) for additional commands.
 
|-
 
|-
 
|/boot/zfsboot
 
|/boot/zfsboot
Line 212: Line 212:
 
|-
 
|-
 
|/boot/zfsloader
 
|/boot/zfsloader
|[https://www.unix.com/man-page/freebsd/8/zfsloader/ zfsloader is an extended variant] of [https://www.unix.com/man-page/freebsd/8/loader/ loader(8)] with added support for booting from ZFS.  This document describes only differences from [https://www.unix.com/man-page/freebsd/8/loader/ loader(8).]
+
|[https://www.unix.com/man-page/freebsd/8/zfsloader/ zfsloader is an extended variant] of loader(8) with added support for booting from ZFS.  This document describes only differences from loader(8).]
  
 
|}
 
|}
  
 
[[Category:Sysutils]]
 
[[Category:Sysutils]]

Please note that all contributions to GhostBSD Wiki are considered to be released under the Creative Commons Attribution (see GhostBSD Wiki:Copyrights for details). If you do not want your writing to be edited mercilessly and redistributed at will, then do not submit it here.
You are also promising us that you wrote this yourself, or copied it from a public domain or similar free resource. Do not submit copyrighted work without permission!

To edit this page, please answer the question that appears below (more info):

Cancel | Editing help (opens in new window)