Editing How To

Jump to: navigation, search

Warning: You are not logged in. Your IP address will be publicly visible if you make any edits. If you log in or create an account, your edits will be attributed to your username, along with other benefits.

The edit can be undone. Please check the comparison below to verify that this is what you want to do, and then save the changes below to finish undoing the edit.
Latest revision Your text
Line 74: Line 74:
 
Eric Turgeon, [12.03.20 02:07] on Telegram
 
Eric Turgeon, [12.03.20 02:07] on Telegram
  
* <code>pkg upgrade -f</code>
+
* <code>os pkg upgrade</code>
 +
 
 +
 
 +
===For anyone wanting to play with a GhostBSD livecd without X===
 +
 
 +
I have one at ftp://219.121.16.20/pub/GhostBSD/experimental/GhostBSD-2020-03-19-nox-experimental.iso 
 +
 
 +
It is not very useful at the moment, but may be of interest to some. It does not come with an installer yet.
 +
 
 +
For network, run: dhcpcd
 +
 
 +
It is read-writable, and packages can be added.
 +
Tip from Vic Thacker on Telegram on 19.3.2020 at 6:38
  
 
===Is there a way to burn an .iso on GhostBSD to usb?===
 
===Is there a way to burn an .iso on GhostBSD to usb?===
Line 86: Line 98:
  
 
* Grub on linux does not see FreeBSD same for Grub on FreeBSD it does not see Linux.
 
* Grub on linux does not see FreeBSD same for Grub on FreeBSD it does not see Linux.
* The best thing I have come up with is Refind, but it only work with efi.
+
* The best thing I have comeup with is Refind, but it only works with efi.
* You can set up Grub to config file to add GhostBSD, but it is diferent on MBR, GPT, UEFI, legacy boot
+
* You can set up Grub to config file to add GhostBSD, but it is different on MBR, GPT, UEFI, legacy boot
 
* If you google it for FreeBSD you will find the way you need to set it.
 
* If you google it for FreeBSD you will find the way you need to set it.
  
Line 99: Line 111:
 
* To make it permanently available use EFIFS's UFS2 driver, place it in the "/EFI/refind/driver_x64", and edit the edit the "refind.conf" to distinguish which "/boot/*.efi" should be loaded and visible at boot.
 
* To make it permanently available use EFIFS's UFS2 driver, place it in the "/EFI/refind/driver_x64", and edit the edit the "refind.conf" to distinguish which "/boot/*.efi" should be loaded and visible at boot.
 
* Don't know the exact configuration, but that's the gist.
 
* Don't know the exact configuration, but that's the gist.
 
  
 
=== Filesystem repairs===
 
=== Filesystem repairs===
Line 271: Line 282:
 
===How to find Software on GhostBSD===
 
===How to find Software on GhostBSD===
 
* Go to [[GhostBSD Wiki]] or [[Applications]]
 
* Go to [[GhostBSD Wiki]] or [[Applications]]
* Than to [[Application Management]] and choose your preferred method for installation.
+
* Then to [[Application Management]] and choose your preferred method for installation.
  
 
===How to install software?===
 
===How to install software?===
Line 297: Line 308:
  
 
===Like to change the display manager===
 
===Like to change the display manager===
Edit /etc/rc.conf. Put a # before the lightdm_enable="YES" line to disable lightdm.
+
<code>sudo rc-update delete lightdm</code><br/>
Then put this new line in: gdm_enable="YES"
+
<code>sudo rc-update add gdm</code><br/>
 +
Tip from Eric on Telegram at 27.01.2020 17:09
  
 
===Migrate from Linux to GhostBSD and take your E-Mails and bookmarks with you===
 
===Migrate from Linux to GhostBSD and take your E-Mails and bookmarks with you===
Line 371: Line 383:
  
 
Eric Turgeon, [04.06.20 18:49] on telegram<br/>
 
Eric Turgeon, [04.06.20 18:49] on telegram<br/>
actualy in <code> ~/.config/fish/cofing.fish</code>
+
actualy in <code> ~/.config/fish/config.fish</code>
  
 
Pino Cuccaro, [05.06.20 11:26] an telegram<br/>
 
Pino Cuccaro, [05.06.20 11:26] an telegram<br/>
Line 682: Line 694:
 
* Open a terminal
 
* Open a terminal
 
* Change to root
 
* Change to root
* usbconfig list    or  usbconfig -d ugenX.Y dump_device_desc
 
 
* Write: [https://www.freebsd.org/cgi/man.cgi?query=gpart&sektion=8&apropos=0&manpath=FreeBSD+12.1-RELEASE+and+Ports <nowiki># gpart show</nowiki>]
 
* Write: [https://www.freebsd.org/cgi/man.cgi?query=gpart&sektion=8&apropos=0&manpath=FreeBSD+12.1-RELEASE+and+Ports <nowiki># gpart show</nowiki>]
* gpart will show you the device da'''x''' and the partition s'''x'''  
+
* gpart will show you the device da'''x''' and the partition s'''x'''
* gpart show  or  gpart show -lp  or  gpart status  or  geom disk list or camcontrol devlist
+
* gpart show /dev/da0  or  gpart show da0 or gpart show ada0
+
 
+
 
+
===mount exFat===
+
* sudo pkg search exfat
+
* sudo pkg install fusefs-exfat
+
* pkg info  fuesfs-exfat
+
* sudo mount.exfat-fuse /dev/da0p1 /media/da0p1
+
* FUSE exfat 1.3.0
+
* mount
+
* /dev/da0p2 on /media/da0p2 (msdosfs, local, noatime)
+
* /dev/da0p1 on /media/da0p1 (fusefs)
+
* ls -l /media/da0p1
+
* umount /dev/da0p1  or umount /media/da0p1
+
* ls -l /media
+
  
 
===mount NTFS===
 
===mount NTFS===
Line 706: Line 701:
 
* Do first <code>gpart show</code>  
 
* Do first <code>gpart show</code>  
 
* Install: '''ntfs-3g'''
 
* Install: '''ntfs-3g'''
* pkg search ntfs
 
* pkg info fusefs-ntfs
 
* pkg list fusefs-ntfs
 
* pkg install fusefs-ntfs
 
 
* Write: <code># ntfs-3g /dev/da5s1 /mnt</code>
 
* Write: <code># ntfs-3g /dev/da5s1 /mnt</code>
 
* da5s1 is an example
 
* da5s1 is an example
* /mnt is the mountpoint directory you wish to use
+
* /mnt is the mountpoint you wish
* open Thunar and go to /mnt directory to view files mounted there from /dev/da5s1
+
* open Thunar and go to /mnt
 
* Thunar shows you the content of your device and you can work with it
 
* Thunar shows you the content of your device and you can work with it
* Caja does not always show you contents
+
* Caja does not allways
* ls -lh /mnt
+
* mount
+
* ls -lh /media
+
* umount /mnt or unmount /dev/da5s1
+
 
+
 
Source: Tested by [[User:Slughorn|Slughorn]]<br/>
 
Source: Tested by [[User:Slughorn|Slughorn]]<br/>
 
Thanks to:[https://forums.ghostbsd.org/viewtopic.php?f=91&t=1532 user hunghung]
 
Thanks to:[https://forums.ghostbsd.org/viewtopic.php?f=91&t=1532 user hunghung]
Line 738: Line 724:
  
 
----
 
----
 +
  
 
==[[System]] management==
 
==[[System]] management==

Please note that all contributions to GhostBSD Wiki are considered to be released under the Creative Commons Attribution (see GhostBSD Wiki:Copyrights for details). If you do not want your writing to be edited mercilessly and redistributed at will, then do not submit it here.
You are also promising us that you wrote this yourself, or copied it from a public domain or similar free resource. Do not submit copyrighted work without permission!

To edit this page, please answer the question that appears below (more info):

Cancel | Editing help (opens in new window)

Template used on this page: