Editing How to build GhostBSD?

Jump to: navigation, search

Warning: You are not logged in. Your IP address will be publicly visible if you make any edits. If you log in or create an account, your edits will be attributed to your username, along with other benefits.

The edit can be undone. Please check the comparison below to verify that this is what you want to do, and then save the changes below to finish undoing the edit.
Latest revision Your text
Line 10: Line 10:
 
* Hybrid DVD/USB image<br/>
 
* Hybrid DVD/USB image<br/>
  
==Graphics Support==
+
==Graphics support==
  
 
* Compatible with VirtualBox, VMware, NVIDIA graphics out of box<br/>
 
* Compatible with VirtualBox, VMware, NVIDIA graphics out of box<br/>
Line 16: Line 16:
 
* Intel/AMD graphics
 
* Intel/AMD graphics
  
==System Requirements for Latest Version of GhostBSD==
+
==System requirements for Latest version of GhostBSD==
  
 
* 20GB of free disk space<br/>
 
* 20GB of free disk space<br/>
Line 22: Line 22:
  
 
'''Note:''' GhostBSD 19.09 and later should be used to build ISO.
 
'''Note:''' GhostBSD 19.09 and later should be used to build ISO.
 
  
 
==Setup==
 
==Setup==
  
===Initial Setup===
 
  
* Install the required packages
+
===Initial setup===
 +
 
 +
Install the required packages
  
 
<code>pkg install git transmission-cli rsync</code>
 
<code>pkg install git transmission-cli rsync</code>
  
* Make sure to have linux64 kernel module loaded
+
Make sure to have linux64 kernel module loaded
  
 
<code>kldload linux64</code><br/>
 
<code>kldload linux64</code><br/>
 
<code>sysrc -f /etc/rc.conf kld_list="linux64"</code>
 
<code>sysrc -f /etc/rc.conf kld_list="linux64"</code>
  
===Clone the Repo===
+
===Clone the repo===
  
 
<code>git clone https://www.github.com/ghostbsd/ghostbsd-build.git</code>
 
<code>git clone https://www.github.com/ghostbsd/ghostbsd-build.git</code>
  
  
==Starting a Build==
+
==Starting a build==
  
* Enter the directory for running the LiveCD build script:
+
Enter the directory for running the LiveCD build script:
  
 
<code>cd ghostbsd-build</code>
 
<code>cd ghostbsd-build</code>
  
* To build a GhostBSD with '''MATE''' as default desktop
+
To build a GhostBSD with '''MATE''' as default desktop
  
 
<code>./build.sh</code>
 
<code>./build.sh</code>
Line 56: Line 56:
 
<code>./build.sh -d mate</code>
 
<code>./build.sh -d mate</code>
  
* '''Option:''' To build GhostBSD with '''XFCE''' as default desktop
+
'''Option:''' To build GhostBSD with '''XFCE''' as default desktop
  
 
<code>./build.sh -d xfce</code>
 
<code>./build.sh -d xfce</code>
  
* '''Option:''' To build GhostBSD with '''Cinnamon''' as default desktop
+
'''Option:''' To build GhostBSD with '''Cinnamon''' as default desktop
  
 
<code>./build.sh -d cinnamon</code>
 
<code>./build.sh -d cinnamon</code>
  
* '''Option:''' To build GhostBSD the default '''KDE''' desktop
+
'''Option:''' To build GhostBSD the default '''KDE''' desktop
  
 
<code>./build.sh -d kde</code>
 
<code>./build.sh -d kde</code>
  
* '''Option:''' To build GhostBSD '''release MATE''' desktop
+
'''Option:''' To build GhostBSD '''release MATE''' desktop
  
 
<code>./build.sh -r release</code>
 
<code>./build.sh -r release</code>
Line 76: Line 76:
 
<code>./build.sh -d mate -r release</code>
 
<code>./build.sh -d mate -r release</code>
  
* '''Option:''' To build GhostBSD '''development MATE''' desktop iso
+
'''Option:''' To build GhostBSD '''development MATE''' desktop iso
  
 
<code>./build.sh</code>
 
<code>./build.sh</code>
Line 93: Line 93:
  
 
'''Source''' https://github.com/ghostbsd/ghostbsd-build
 
'''Source''' https://github.com/ghostbsd/ghostbsd-build
 
 
 
 
===[[File:KhostBSD.png|35px|link=]] KhostBSD (GhostBSD KDE Community Build)===
 
 
If you looking for GhostBSD with KDE Plasma 5, you can find it at:
 
 
ftp://219.121.16.20/pub/KhostBSD/GhostBSD19.09-2019-08-17-KDE.iso It is an unofficial iso. Once booted you will need to open a terminal and run:
 
 
<code>sudo gbi</code>
 
 
Gbi is the installer program.
 
 
Author:Vic Thacker
 
 
[[GBI]] is the GhostBSD front end user interface for pc-sysinstall [https://github.com/ghostbsd/ghostbsd-ports/blob/master/sysutils/gbi/pkg-descr]
 
 
===Some Instructions===
 
 
From khostbsd build instructions:
 
 
Live media creator for GhostBSD distribution
 
Introduction
 
 
'''System Requirements'''
 
 
    Latest version of GhostBSD or TrueOS
 
    20GB of free disk space
 
    4GB of free memory
 
 
'''Note:''' GhostBSD 19.04 and earlier releases cannot be used to build ISO.
 
 
'''Initial Setup'''
 
 
* Install the required packages:
 
 
  <code>pkg install git transmission-cli rsync</code>
 
 
* Make sure to have linux64 kernel module loaded
 
 
  <code>kldload linux64</code>
 
  <code>sysrc -f /etc/rc.conf kld_list="linux64"</code>
 
 
* Clone the repo:
 
 
  <code>git clone https://www.github.com/ghostbsd/ghostbsd-build.git</code>
 
 
* Enter the directory for running the LiveCD build script:
 
 
  <code>cd ghostbsd-build</code>
 
 
*To build a GhostBSD with KDE as default desktop
 
 
<code>./build.sh kde</code>
 
 
* Burn an image to cd:
 
 
  <code>cdrecord /usr/local/ghostbsd-build/iso/GhostBSD18.12.iso</code>
 
 
* Write an image to usb stick:
 
 
  <code>dd if=/usr/local/ghostbsd-build/iso/GhostBSD18.12.iso of=/dev/da0 bs=4m </code>
 
 
===If You Download KDE From Ports ===
 
 
Be sure to install all of the needed packages. Here is an example from Vic Thacker on Telegram from 13.01.2010:  https://github.com/ghostbsd/ghostbsd-build/blob/master/packages/kde
 

Please note that all contributions to GhostBSD Wiki are considered to be released under the Creative Commons Attribution (see GhostBSD Wiki:Copyrights for details). If you do not want your writing to be edited mercilessly and redistributed at will, then do not submit it here.
You are also promising us that you wrote this yourself, or copied it from a public domain or similar free resource. Do not submit copyrighted work without permission!

To edit this page, please answer the question that appears below (more info):

Cancel | Editing help (opens in new window)