Editing How to install Nvidia drivers

Jump to: navigation, search

Warning: You are not logged in. Your IP address will be publicly visible if you make any edits. If you log in or create an account, your edits will be attributed to your username, along with other benefits.

The edit can be undone. Please check the comparison below to verify that this is what you want to do, and then save the changes below to finish undoing the edit.
Latest revision Your text
Line 8: Line 8:
 
===Frostygoth===
 
===Frostygoth===
  
on Telegram on 24.01.2020 at 21:18
+
on Telegram on 24.01.2010 at 21:18
  
<code>sudo pkg install nvidia-driver-440.31</code> <br/>
+
<code>sudo pkg install nvidia-driver-440.31</code> will install the latest nvidia driver from pkg
 
+
will install the latest nvidia driver from pkg
+
  
 
'''But how to apply it'''
 
'''But how to apply it'''
  
on Telegram on 24.01.2020 at 21:24 -51
+
on Telegram on 24.01.2010 at 21:24 -51
  
<code>kldload_nvidia="nvidia-modeset nvidia</code> <br/>
+
<code>kldload_nvidia="nvidia-modeset nvidia</code>  
 +
set in
 +
<code> /etc/rc.conf</code> file;
  
set in <br/>
+
Also set the line  
 
+
<code>Driver "nvidia</code> in <code> /etc/X11/xorg.conf</code>
<code> /etc/rc.conf</code> <br/>file;
+
 
+
Also set the line <br/>
+
 
+
<code>Driver "nvidia</code> <br/> in<br/> <code> /etc/X11/xorg.conf</code>
+
 
+
You need to install the driver with <br/>
+
 
+
<code>pkg install nvidia-driverXXXXX</code>. <br/>
+
 
+
Then once it's installed you want to make sure that you load the driver at boot by making sure that the
+
 
+
line <br/>
+
 
+
<code>kldload_nvidia="nvidia-modeset nvidia</code><br/>
+
 
+
is present in your<br/>
+
  
 +
You need to install the driver with
 +
<code>pkg install nvidia-driverXXXXX</code>.
 +
Then once it's installed you want to make sure that you load the driver at boot by making sure that the line
 +
<code>kldload_nvidia="nvidia-modeset nvidia</code>
 +
is present in your
 
<code>/etc/rc.conf</code> file.  
 
<code>/etc/rc.conf</code> file.  
  
You may need to add this line to <br/>
+
You may need to add this line to  
 
+
<code>/etc/rc.conf</code>.
<code>/etc/rc.conf</code>.<br/>
+
You also need to make sure that your  
 
+
<code>/etc/X11/xorg.conf</code> file has the Driver identified as "nvidia", which may require you to replace 'nv' with 'nvidia'.
You also need to make sure that your <br/>
+
</br> kldload_nvidia="nvidia-modeset nvidia" —> /etc/rc.conf
 
+
<code>/etc/X11/xorg.conf</code> <br/>
+
 
+
file has the Driver identified as "nvidia", which may require you to replace 'nv' with 'nvidia'.<br/>  
+
 
+
kldload_nvidia="nvidia-modeset nvidia" —> ''/etc/rc.conf''
+
  
 
Driver "nvidia" —> /etc/X11/xorg.conf
 
Driver "nvidia" —> /etc/X11/xorg.conf
  
<code>kldload | grep nvidia </code> <br/>
+
<code>kldload | grep nvidia </code>  
 +
That'll tell you if the drivers are loaded at least</br>
  
That'll tell you if the drivers are loaded at least<br/>
+
But as long as you've got the <code>kldload_nvidia="nvidia-modeset nvidia</code> line in your /etc/rc.conf then they'll load automatically after a reboot.
 
+
But as long as you've got the  
+
 
+
<code>kldload_nvidia="nvidia-modeset nvidia</code>  
+
 
+
line in your ''/etc/rc.conf'' then they'll load automatically after a reboot.
+
  
 
'''Attantion'''
 
'''Attantion'''
The entire folder of /etc/X11 on GhostBSD is empty. It might be, that this suggestion is not help. Or it has to get installed from the ports. See [[How to install Nvidia drivers#Additional Information|Additional Information]].
+
The entire folder of /etc/X11 is empty. It might be, that this suggestion is not help.
  
 
===Lilly Elijah Victoria Evans===  
 
===Lilly Elijah Victoria Evans===  
  
on Telegram on 24.01.2020 at 21:48 and confirmation from Neville Goddard 25.01.2020 00:11
+
on Telegram on 24.01.2010 at 21:48 and confirmation from Neville Goddard 25.01.2020 00:11
  
 
'''But how to apply it'''
 
'''But how to apply it'''
Line 80: Line 57:
  
 
===Neville Goddard===
 
===Neville Goddard===
on Telegram on 16.02.2020 at 04:10
+
on Telegram on 16.02.2010 at 04:10
  
Run nvidia-xconfig then reboot
+
Run nvidia-xconfig Then reboot
  
 
===John R===
 
===John R===
on Telegram on 16.02.2020 at 04:16
+
on Telegram on 16.02.2010 at 04:16
  
 
First install required packages:
 
First install required packages:
Line 97: Line 74:
 
<code>nvidia-xconfig</code>
 
<code>nvidia-xconfig</code>
  
Then reboot.
+
Then reboot
  
This will create the needed file.
+
This will create the needed file
  
 
You shouldn't need to edit this.
 
You shouldn't need to edit this.
Line 105: Line 82:
  
  
===Additional Information===
 
 
NVIDIA FreeBSD Graphics Driver Archive: https://www.nvidia.com/en-us/drivers/unix/freebsd-archive/
 
 
FreeBSD Display Driver – x64 https://www.nvidia.de/Download/driverResults.aspx/142666/de
 
 
Setting up the FreeBSD nVidia driver: [https://docs.freebsd.org/doc/7.3-RELEASE/usr/share/doc/en/articles/compiz-fusion/nvidia-setup.html docs]:
 
* The latest versions of nVidia cards are supported by the x11/nvidia-driver port.
 
* nVidia cards like the GeForce 2MX/3/4 series are supported by the 96XX series of drivers, available in the x11/nvidia-driver-96xx port.
 
* Even older cards, like GeForce and RIVA TNT are supported by the 71XX series of drivers, available in the x11/nvidia-driver-71xx port.
 
 
'''Installing the nVidia driver'''
 
For example, to install the latest driver:
 
 
<code><nowiki>#</nowiki> cd /usr/ports/x11/nvidia-driver</code><br/>
 
<code><nowiki>#</nowiki> make install clean</code>
 
 
===Discussions on the GhostBSD Forum===
 
 
* [https://forums.ghostbsd.org/viewtopic.php?f=65&t=946 NVIDIA Madness on 11.1]  [SOLVED]
 
 
* [https://forums.ghostbsd.org/viewtopic.php?f=65&t=385 Nvidia problem]  [SOLVED]
 
 
* [https://forums.ghostbsd.org/viewtopic.php?f=65&t=465 nVidia drivers on 10.3]  [SOLVED]
 
 
* [https://forums.ghostbsd.org/viewtopic.php?f=65&t=452 installing nvidia driver]
 
 
* [https://forums.ghostbsd.org/viewtopic.php?f=65&t=392 Nvidia driver install best version.]
 
  
  
Line 144: Line 93:
  
  
{|class="wikitable" style="width:96.5%;background:#FFFFFF; border:2px solid #008000;text-align:center;padding: 10px"  
+
{|class="wikitable" style="width:96.5%;background:#FFFFFF; border:2px solid #008000;text-align:left;padding: 10px"  
 
|-
 
|-
 
|'''Back to ''' [[image:Icon Disti GhostBSD.png|50px|link=How To]] '''How To'''
 
|'''Back to ''' [[image:Icon Disti GhostBSD.png|50px|link=How To]] '''How To'''

Please note that all contributions to GhostBSD Wiki are considered to be released under the Creative Commons Attribution (see GhostBSD Wiki:Copyrights for details). If you do not want your writing to be edited mercilessly and redistributed at will, then do not submit it here.
You are also promising us that you wrote this yourself, or copied it from a public domain or similar free resource. Do not submit copyrighted work without permission!

To edit this page, please answer the question that appears below (more info):

Cancel | Editing help (opens in new window)

Template used on this page: