Editing Nvidia driver installation

Jump to: navigation, search

Warning: You are not logged in. Your IP address will be publicly visible if you make any edits. If you log in or create an account, your edits will be attributed to your username, along with other benefits.

The edit can be undone. Please check the comparison below to verify that this is what you want to do, and then save the changes below to finish undoing the edit.
Latest revision Your text
Line 1: Line 1:
To play games or use 3D CAD software, you need to install Nvidia  driver.
+
To play games or use 3D CAD software you need to install Nvidia driver.
  
= Install using package manager =
+
== Install using ports ==
First you should search for available drivers packages:
+
: <code>pkg search nvidia</code>
+
you will get something like this:
+
<pre>
+
linux-nvidia-libs-460.80      NVidia graphics libraries and programs (Linux version)
+
linux-nvidia-libs-304-304.137  NVidia graphics libraries and programs (Linux version)
+
linux-nvidia-libs-340-340.108  NVidia graphics libraries and programs (Linux version)
+
linux-nvidia-libs-390-390.143  NVidia graphics libraries and programs (Linux version)
+
nvidia-driver-460.80          NVidia graphics card binary drivers for hardware OpenGL rendering
+
nvidia-driver-304-304.137_8    NVidia graphics card binary drivers for hardware OpenGL rendering
+
nvidia-driver-340-340.108_2    NVidia graphics card binary drivers for hardware OpenGL rendering
+
nvidia-driver-390-390.143      NVidia graphics card binary drivers for hardware OpenGL rendering
+
nvidia-settings-460.73.01      Display Control Panel for X NVidia driver
+
nvidia-texture-tools-2.0.8.1_23 Texture Tools with support for DirectX 10 texture formats
+
nvidia-xconfig-460.73.01      Tool to manipulate X configuration files for the NVidia driver
+
nvidia_gpu_prometheus_exporter-g20181028_1 NVIDIA GPU Prometheus exporter
+
</pre>
+
  
If you want to install the latest Nvidia driver, just enter:
+
Download the GhostBSD  10.3 kernel source code for [ftp://ftp.freebsd.org/pub/FreeBSD/releases/i386/10.3-RELEASE/src.txz i386] or [ftp://ftp.freebsd.org/pub/FreeBSD/releases/amd64/10.3-RELEASE/src.txz x86_64].
: <code>sudo pkg install nvidia-driver</code>
+
  
If you want to install an old Nvidia driver, just enter:
+
Download the GhostBSD  11.0 kernel source code for [ftp://ftp.freebsd.org/pub/FreeBSD/releases/i386/11.0-RELEASE/src.txz i386] or [ftp://ftp.freebsd.org/pub/FreeBSD/releases/amd64/11.0-RELEASE/src.txz x86_64].
: <code>sudo pkg install nvidia-driver-340</code>
+
  
If you want to use Linux Games and Steam, install '''linux-nvidia-libs''' matching your driver.
+
Download the GhostBSD  11.1 kernel source code for [ftp://ftp.freebsd.org/pub/FreeBSD/releases/i386/11.1-RELEASE/src.txz i386] or [ftp://ftp.freebsd.org/pub/FreeBSD/releases/amd64/11.1-RELEASE/src.txz x86_64].
  
There is additional tool to configure nvidia:
+
Download the GhostBSD 19.09 kernel source code for [ftp://ftp.freebsd.org/pub/FreeBSD/releases/i386/12.0-RELEASE/src.txz i386] or [ftp://ftp.freebsd.org/pub/FreeBSD/releases/amd64/12.0-RELEASE/src.txz x86_64].
  
GUI
 
: <code>sudo pkg install nvidia-settings</code>
 
CLI
 
: <code>sudo pkg install nvidia-xconfig</code>
 
  
= Setting up GhostBSD to use Nvidia =
+
Unpack it in the directory {{file|/usr/src}}.
If you use an AGP nvidia card run the next command.
+
: <code>echo 'hint.agp.0.disabled="1"' >> /boot/device.hints</code>
+
  
== Autoload the Nvidia driver in /etc/rc.conf ==
+
Update you ports tree:
 +
: <code> portsnap fetch update</code>
 +
Get inside needed driver (ex. nvidia-drivers-340):
 +
: <code>cd /usr/ports/x11/nvidia-drivers-340</code>
 +
Compile it
 +
: <code>make install clean</code>
  
For nvivia driver after 367.35 nvidia-modeset must be loaded:
+
Install nvidia-xconfig utility and create xorg.conf file with it
: <code>sysrc -f /etc/rc.conf kldload_nvidia="nvidia-modeset"</code>
+
: <code>cd /usr/ports/x11/nvidia-xconfig</code>
For the nvivia driver 304 or 340 nvidia must be loaded:
+
: <code>make install clean</code>
: <code>kldload_nvidia="nvidia"</code>
+
: <code>nvidia-xconfig</code>
  
== Adding /etc/X11/xorg.conf ==
+
== Install using package manager ==
 +
First you should search for available drivers packages:
 +
: <code>pkg search nvidia</code>
 +
you will get something like this:
 +
<pre>
 +
nvidia-driver-390.87_3        NVidia graphics card binary drivers for hardware OpenGL rendering
 +
nvidia-driver-304-304.137_4    NVidia graphics card binary drivers for hardware OpenGL rendering
 +
nvidia-driver-340-340.107_4    NVidia graphics card binary drivers for hardware OpenGL rendering
 +
nvidia-settings-430.14        Display Control Panel for X NVidia driver
 +
nvidia-texture-tools-2.0.8.1_13 Texture Tools with support for DirectX 10 texture formats
 +
nvidia-xconfig-430.14          Tool to manipulate X configuration files for the NVidia driver
 +
nvidia_gpu_prometheus_exporter-g20181028  NVIDIA GPU Prometheus exporter
 +
</pre>
 +
Now choose driver and install it:
 +
: <code>pkg install nvidia-driver-340-340.107_4</code>
 +
If you want to install the latest nvidia driver just enter:
 +
: <code>pkg install nvidia-driver</code>
 +
this will install driver version 390.87_3 but there is a slightly different step needed to set it up for GhostBSD. See next section below.
  
Using nvidia-xconfig utility:
+
Also we need to install two additional packages:
: <code>nvidia-xconfig</code>
+
: <code>pkg install nvidia-settings</code>
 +
: <code>pkg install nvidia-xconfig</code>
  
 +
== Setting up GhostBSD to use nvidia ==
 +
If you use and AGP nvidia card run the next command.
 +
: <code>echo 'hint.agp.0.disabled="1"' >> /boot/device.hints</code>
 +
{| style="color:black; background-color:#f3f8fd;" class="wikitable"
 +
|
 +
'''Note:'''
 +
# Using GhostBSD GRUB the driver must be loaded in /etc/rc.conf:
 +
#: <code>echo 'kld_list="nvidia"' >> /etc/rc.conf</code>
 +
# For nvidia drivers later than 367.35 this must be loaded in /etc/rc.conf:
 +
#: <code>echo 'kld_list="nvidia-modeset"' >> /etc/rc.conf</code>
 +
# Using BSD loader or Linux Grub the driver must be loaded in loader.conf:
 +
#: <code>echo 'nvidia_load="YES"' >> /boot/loader.conf</code>
 +
# For the latest nvivia driver (after 367.35) this must be loaded:
 +
#: <code>echo 'nvidia-modeset_load="YES"' >> /boot/loader.conf</code>
 +
|}
 +
 +
 +
Make X configuration file with nvidia-xconfig utility:
 +
: <code>nvidia-xconfig</code>
 
You can reboot your system now:
 
You can reboot your system now:
: <code>shutdown -r now</code>
+
: <code>reboot</code>
  
 
[[category:Nvidia]]
 
[[category:Nvidia]]
 
[[category:driver]]
 
[[category:driver]]

Please note that all contributions to GhostBSD Wiki are considered to be released under the Creative Commons Attribution (see GhostBSD Wiki:Copyrights for details). If you do not want your writing to be edited mercilessly and redistributed at will, then do not submit it here.
You are also promising us that you wrote this yourself, or copied it from a public domain or similar free resource. Do not submit copyrighted work without permission!

To edit this page, please answer the question that appears below (more info):

Cancel | Editing help (opens in new window)