Editing Nvidia driver installation

Jump to: navigation, search

Warning: You are not logged in. Your IP address will be publicly visible if you make any edits. If you log in or create an account, your edits will be attributed to your username, along with other benefits.

The edit can be undone. Please check the comparison below to verify that this is what you want to do, and then save the changes below to finish undoing the edit.
Latest revision Your text
Line 1: Line 1:
 
To play games or use 3D CAD software, you need to install Nvidia  driver.
 
To play games or use 3D CAD software, you need to install Nvidia  driver.
  
= Install using package manager =
+
== Install using package manager ==
 
First you should search for available drivers packages:
 
First you should search for available drivers packages:
 
: <code>pkg search nvidia</code>
 
: <code>pkg search nvidia</code>
Line 22: Line 22:
 
If you want to install the latest Nvidia driver, just enter:
 
If you want to install the latest Nvidia driver, just enter:
 
: <code>sudo pkg install nvidia-driver</code>
 
: <code>sudo pkg install nvidia-driver</code>
 +
 +
This will install the driver version, but there is a slightly different step is needed to set it up for GhostBSD.
  
 
If you want to install an old Nvidia driver, just enter:
 
If you want to install an old Nvidia driver, just enter:
: <code>sudo pkg install nvidia-driver-340</code>
+
: <code>sudo pkg install nvidia-driver</code>
  
If you want to use Linux Games and Steam, install '''linux-nvidia-libs''' matching your driver.
+
Also we need to install two additional packages:
 
+
There is additional tool to configure nvidia:
+
 
+
GUI
+
 
: <code>sudo pkg install nvidia-settings</code>
 
: <code>sudo pkg install nvidia-settings</code>
CLI
 
 
: <code>sudo pkg install nvidia-xconfig</code>
 
: <code>sudo pkg install nvidia-xconfig</code>
  
= Setting up GhostBSD to use Nvidia =
+
== Setting up GhostBSD to use nvidia ==
If you use an AGP nvidia card run the next command.
+
If you use and AGP nvidia card run the next command.
 
: <code>echo 'hint.agp.0.disabled="1"' >> /boot/device.hints</code>
 
: <code>echo 'hint.agp.0.disabled="1"' >> /boot/device.hints</code>
 +
{| style="color:black; background-color:#f3f8fd;" class="wikitable"
 +
|
 +
'''Note:'''
 +
# The driver must be loaded in /etc/rc.conf. Add nvidia-modeset and nvidia to kld_list line.
 +
#: <code>kld_list="nvidia-modeset nvidia"</code>
 +
# The driver must be loaded in loader.conf:
 +
#: <code>echo 'nvidia_load="YES"' >> /boot/loader.conf</code>
 +
# For the latest nvivia driver (after 367.35) this must be loaded:
 +
#: <code>echo 'nvidia-modeset_load="YES"' >> /boot/loader.conf</code>
 +
|}
  
== Autoload the Nvidia driver in /etc/rc.conf ==
 
  
For nvivia driver after 367.35 nvidia-modeset must be loaded:
+
Make X configuration file with nvidia-xconfig utility:
: <code>sysrc -f /etc/rc.conf kldload_nvidia="nvidia-modeset"</code>
+
For the nvivia driver 304 or 340 nvidia must be loaded:
+
: <code>kldload_nvidia="nvidia"</code>
+
 
+
== Adding /etc/X11/xorg.conf ==
+
 
+
Using nvidia-xconfig utility:
+
 
: <code>nvidia-xconfig</code>
 
: <code>nvidia-xconfig</code>
 
 
You can reboot your system now:
 
You can reboot your system now:
: <code>shutdown -r now</code>
+
: <code>reboot</code>
  
 
[[category:Nvidia]]
 
[[category:Nvidia]]
 
[[category:driver]]
 
[[category:driver]]

Please note that all contributions to GhostBSD Wiki are considered to be released under the Creative Commons Attribution (see GhostBSD Wiki:Copyrights for details). If you do not want your writing to be edited mercilessly and redistributed at will, then do not submit it here.
You are also promising us that you wrote this yourself, or copied it from a public domain or similar free resource. Do not submit copyrighted work without permission!

To edit this page, please answer the question that appears below (more info):

Cancel | Editing help (opens in new window)