Editing Useful Commands

Jump to: navigation, search

Warning: You are not logged in. Your IP address will be publicly visible if you make any edits. If you log in or create an account, your edits will be attributed to your username, along with other benefits.

The edit can be undone. Please check the comparison below to verify that this is what you want to do, and then save the changes below to finish undoing the edit.
Latest revision Your text
Line 9: Line 9:
  
 
==Common Commands==
 
==Common Commands==
 
===Basic Commands on Your system===
 
 
See also in In your directories
 
* [[/usr/bin/]] [[/usr/sbin/]] useful applications for your cli,
 
* [[/bin/]] and [[/sbin/]] system tools.
 
  
 
===For People New to Both Ghost/FreeBSD and UNIX===
 
===For People New to Both Ghost/FreeBSD and UNIX===
Line 23: Line 17:
  
 
[https://www.freebsd.org/doc/en_US.ISO8859-1/articles/linux-users/commands.html Common Commands]
 
[https://www.freebsd.org/doc/en_US.ISO8859-1/articles/linux-users/commands.html Common Commands]
 
===UNIX Command Summary===
 
 
[https://www.bsd.org/unixcmds.html on BSD.org]
 
 
 
===An introduction to Regular Expressions===
 
 
[https://www.bsd.org/regexintro.html on BSD.org]
 
 
===A concise reference of vi commands===
 
 
[https://www.bsd.org/viref.html on BSD.org]
 
  
 
===FreeBSD Command Reference===
 
===FreeBSD Command Reference===
Line 54: Line 35:
 
===FREEBSD Man Pages ===
 
===FREEBSD Man Pages ===
  
This page gives an overview about all commands and there man pages (12,652 Total Pages):
+
This page gives a overview about all commands and there man pages (12,652 Total Pages):
 
[https://www.unix.com/man-page-collection.php?os=freebsd The UNIX and Linux Forums]
 
[https://www.unix.com/man-page-collection.php?os=freebsd The UNIX and Linux Forums]
 +
  
 
==Selected helpful Commands==
 
==Selected helpful Commands==
Line 61: Line 43:
 
{|class="wikitable" style="width:96.5%;background:#FFFFFF; border:2px solid #008000;text-align:left;padding: 10px"  
 
{|class="wikitable" style="width:96.5%;background:#FFFFFF; border:2px solid #008000;text-align:left;padding: 10px"  
 
|-
 
|-
! scope="col" style="width: 200px;"|'''Command'''
+
! scope="col" style="width: 100px;"|'''Command'''
 
! scope="col" style="width: 350px;"|'''Abstract'''
 
! scope="col" style="width: 350px;"|'''Abstract'''
! scope="col" style="width: 150px;"|'''Addition or Link'''
+
! scope="col" style="width: 250px;"|'''Addition or Link'''
 
|-
 
|-
|sudo [https://www.freebsd.org/cgi/man.cgi?query=pkg-info&sektion=8&apropos=0&manpath=FreeBSD+12.1-RELEASE+and+Ports pkg info] os-generic-userland <nowiki>|</nowiki> grep Version
+
|dmesg
|Shows what version of GhostBSD I am running
+
|The dmesg utility displays the contents of the system message buffer
|[https://forums.ghostbsd.org/viewtopic.php?f=61&p=8353#p8353 ericbsd on the forum]
+
|[https://www.unix.com/man-page/freebsd/8/dmesg/]
 
|-
 
|-
|neofetch||shows your installed version with a beastie logo <br/>Fast, highly customizable system info script. This script gathers info about your system and prints it to the
+
|scanimage -L
terminal next to an image, your distro's logo or any ascii art of
+
|Shows if the scanner is connected and seen
your choice!
+
||https://github.com/dylanaraps/neofetch
+
|-
+
|[[sysctl]] kern.osreldate
+
|Shows the same result as uname -U
+
|[https://www.freebsd.org/cgi/man.cgi?query=sysctl&sektion=8&apropos=0&manpath=FreeBSD+12.1-RELEASE+and+Ports sysctl(8)]
+
|-
+
|[https://www.freebsd.org/cgi/man.cgi?query=uname&apropos=0&sektion=0&manpath=FreeBSD+12.1-RELEASE+and+Ports&arch=default&format=html uname] -U
+
|you get: 1201500 or higher; part 1201 comes from FreeBSD-version 12.01 and 500 seems to bee the level of contribs.
+
|see also [https://forums.ghostbsd.org/viewtopic.php?f=91&t=1556 ericbsd]; [https://www.cyberciti.biz/faq/how-to-find-out-freebsd-version-and-patch-level-number/ nixCraft Linux and Unix tutorials for new and seasoned sysadmin]
+
|-
+
|[[OpenRC]]
+
|command scripts for auto-reboot and daemon startup
+
Files
+
/etc/[[Rc|rc]]
+
/etc/[[rc.conf]]
+
/etc/rc.conf.local
+
/etc/[[rc.d]]/
+
/etc/rc.firewall
+
/etc/rc.local
+
/etc/rc.shutdown
+
/etc/rc.subr
+
/var/run/dmesg.boot
+
|[[File:Jean victor balin book.png|25px|link=https://www.freebsd.org/cgi/man.cgi?query=rc&apropos=0&sektion=8&manpath=FreeBSD+12.1-RELEASE+and+Ports&arch=default&format=html]]
+
|-
+
|[[dmesg]]
+
|Discover what hardware was detected by the kernel and other system related information.
+
|[[File:Jean victor balin book.png|25px|link=https://www.unix.com/man-page/freebsd/8/dmesg/]]
+
|-
+
|dmesg <nowiki>|</nowiki> grep usb
+
|Show USB devices.
+
|
+
|-
+
|[[kldstat]]
+
|List all modules currently loaded in the kernel.
+
 
|
 
|
 
|-
 
|-
 
|gpart
 
|gpart
 
|The gpart utility is used to partition GEOM providers, normally disks
 
|The gpart utility is used to partition GEOM providers, normally disks
|[[File:Jean victor balin book.png|25px|link=https://www.unix.com/man-page/freebsd/8/gpart/]]
+
|[https://www.unix.com/man-page/freebsd/8/gpart/]
 
|-
 
|-
 
|mount -t msdosfs /dev/da5s1 /mnt
 
|mount -t msdosfs /dev/da5s1 /mnt
 
|mount USB stick, the numbers 5 and 1 are exables, you have to get them with gpart for your system
 
|mount USB stick, the numbers 5 and 1 are exables, you have to get them with gpart for your system
|[[File:Jean victor balin book.png|25px|link=https://www.unix.com/man-page/freebsd/5/msdosfs/]]
+
|
 
|-
 
|-
 
|ntfs-3g /dev/da'''x'''s'''y''' /mnt
 
|ntfs-3g /dev/da'''x'''s'''y''' /mnt
 
|mount NTFS device  
 
|mount NTFS device  
 
|
 
|
|-
+
 
|pciconf -lv 
+
|Output to identify your video card
+
|Fred Finster 10.01.2020 on Telegram, see also [[File:Jean victor balin book.png|25px|link=https://www.unix.com/man-page/freebsd/8/pciconf/]]
+
|-
+
|pciconf -l -cv
+
|Show PCI devices.
+
|[[File:Jean victor balin book.png|25px|link=https://www.unix.com/man-page/freebsd/8/pciconf/]]
+
|-
+
|scanimage -L
+
|Shows if the scanner is connected and seen
+
|[[File:Icon FreeBSD.png|100px|link=https://www.bsdforen.de/threads/scanner-device-in-qt5-variable-einlesen.33977/]] [[File:1329059652.png|35px|link=http://www.sane-project.org/man/scanimage.1.html]]
+
|-
+
|[[sysctl]] hw.realmem
+
|Display hardware memory.
+
|[[File:Jean victor balin book.png|25px|link=https://www.unix.com/man-page/freebsd/8/sysctl/]]
+
|-
+
|[[sysctl]] dev <nowiki>|</nowiki> less
+
|Display configured devices.
+
|
+
|-
+
|[[sysctl]] hw.model
+
|Display CPU model.
+
|[[File:Jean victor balin book.png|25px|link=https://www.unix.com/man-page/freebsd/8/sysctl/]]
+
|-
+
|[[sysctl]] hw.machine_arch
+
|Display CPU Architecture
+
|[[File:Jean victor balin book.png|25px|link=https://www.unix.com/man-page/freebsd/8/sysctl/]]
+
|-
+
|[[sysctl]] hw.ncpu
+
|Display number of CPUs.
+
|[[File:Jean victor balin book.png|25px|link=https://www.unix.com/man-page/freebsd/8/sysctl/]]
+
|-
+
|uname -vm
+
|Get release version information.
+
|[[File:Jean victor balin book.png|25px|link=https://www.unix.com/man-page/freebsd/1/uname/]]
+
|-
+
|uname -a
+
|Get release version and user.pc information
+
|[[File:Jean victor balin book.png|25px|link=https://www.unix.com/man-page/freebsd/1/uname/]]
+
|-
+
|freebsd-version
+
|print the version and patch level of the installed base system: FreeBSD, Info is located <code>/bin/freebsd-version</code> on your system
+
|[[File:Jean victor balin book.png|25px|link=https://www.unix.com/man-page/freebsd/1/freebsd-version/]]
+
 
|-
 
|-
 
!colspan="3"|
 
!colspan="3"|
Line 168: Line 72:
 
!colspan="3"|'''Back to the''' [[image:Icon Disti GhostBSD.png|50px|link=GhostBSD Wiki]]''' Wiki'''
 
!colspan="3"|'''Back to the''' [[image:Icon Disti GhostBSD.png|50px|link=GhostBSD Wiki]]''' Wiki'''
 
|}
 
|}
 
 
[[Category:Sysutils]]
 

Please note that all contributions to GhostBSD Wiki are considered to be released under the Creative Commons Attribution (see GhostBSD Wiki:Copyrights for details). If you do not want your writing to be edited mercilessly and redistributed at will, then do not submit it here.
You are also promising us that you wrote this yourself, or copied it from a public domain or similar free resource. Do not submit copyrighted work without permission!

To edit this page, please answer the question that appears below (more info):

Cancel | Editing help (opens in new window)